Skip to content

DivisionPoints

Canonical path: NemAll_Python_Geometry.DivisionPoints

Class for DivisionPoints

Methods:

Count

Count() -> int

Get number of division points

Returns:

  • int

    number of division points

GetEndPoint

GetEndPoint() -> Point3D

Get the end point

Returns:

GetEndPointAngle

GetEndPointAngle() -> Angle

Get the angle at the end point

Returns:

  • Angle

    Angle at the end point

GetPoint

GetPoint(index: int) -> Point3D

Get division point

Parameters:

  • index (int) –

    index of the division point

Returns:

  • Point3D

    division point as Point3D

GetPointAngle

GetPointAngle(index: int) -> Angle

Get the angle of a division point

Parameters:

  • index (int) –

    index of the division point

Returns:

  • Angle

    angle as Angle

GetPointAngles

GetPointAngles() -> AngleList

Get the angles of the division points

Returns:

  • AngleList

    copy of the angles of the division points as vector of Angle

GetPoints

GetPoints() -> Point3DList

Get the calculated division points

Returns:

  • Point3DList

    copy of the division points as vector of Point3D

GetStartPoint

GetStartPoint() -> Point3D

Get the start point

Returns:

GetStartPointAngle

GetStartPointAngle() -> Angle

Get the angle at the start point

Returns:

  • Angle

    Angle at the start point

IsSuccessful

IsSuccessful() -> bool

Get the result of the computation

Returns:

  • bool

    Computation successful: true / false

__init__ overloaded

__init__(path: Path2D, sectionLength: float, eps: float)

Constructor

Parameters:

  • path (Path2D) –

    Path to divide

  • sectionLength (float) –

    length of one division section

  • eps (float) –

    tolerance

__init__(geoObject: object, number: int, eps: float)

Constructor

Parameters:

  • geoObject (object) –

    object to divide

  • number (int) –

    number of division points

  • eps (float) –

    tolerance

__init__(path: Path2D, number: int, eps: float)

Constructor

Parameters:

  • path (Path2D) –

    Path to divide

  • number (int) –

    number of division points

  • eps (float) –

    tolerance

__init__(geoObject: object, sectionLength: float, eps: float)

Constructor

Parameters:

  • geoObject (object) –

    object to divide

  • sectionLength (float) –

    length of one division section

  • eps (float) –

    tolerance