Skip to content

InputStringConvert

Canonical path: NemAll_Python_IFW_Input.InputStringConvert

Representation of the prompt shown in Allplan UI in the so called dialog line during an input (selection or point input)

Methods:

  • GetString

    Get the input string

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

GetString

GetString() -> str

Get the input string

Returns:

  • str

    Input string

__init__ overloaded

__init__(id: int)

Construct the prompt from an ID pointing out to a built-in string

Parameters:

  • arg2

    ID of the build-in prompt

__init__(text: str)

Construct the prompt from any string

Parameters:

  • arg2

    Prompt to show in the dialog line