Skip to content

DoorOpeningProperties

Canonical path: NemAll_Python_ArchElements.DoorOpeningProperties

Implementation of the door opening properties

Methods:

Attributes:

FrenchDoor property writable

FrenchDoor: bool

Get the french door attribute state

Independent2DInteraction property writable

Independent2DInteraction: bool

Get the independent 2D interaction state

PlaneReferences property writable

PlaneReferences: PlaneReferences

Get the plane references

GetDoorSwingProperties

GetDoorSwingProperties() -> DoorSwingProperties

Get a reference of the door swing properties

Returns:

GetGeometryProperties

GetGeometryProperties() -> VerticalOpeningGeometryProperties

Get a reference of the geometry properties

Returns:

GetOpeningSymbolsProperties

GetOpeningSymbolsProperties() -> OpeningSymbolsProperties

Get a reference of the opening symbols properties

Returns:

GetRevealProperties

GetRevealProperties() -> VerticalOpeningRevealProperties

Get a reference of the reveal properties

Returns:

GetSillProperties

GetSillProperties() -> VerticalOpeningSillProperties

Get a reference of the sill properties

Returns:

GetTierOffsetProperties

GetTierOffsetProperties() -> VerticalOpeningTierOffsetProperties

Get a reference of the tier offset properties

Returns:

__init__ overloaded

__init__()

Initialize

__init__(doorProp: DoorOpeningProperties)

Copy constructor

Parameters: