Skip to content

VecUIntList

Canonical path: NemAll_Python_Utility.VecUIntList

Methods:

__contains__

__contains__(value: int) -> bool

Check for a value in the list

Parameters:

  • value (int) –

    Value to check

Returns:

  • bool

    State for value is in the list

__delitem__

__delitem__(value: int)

Delete a list item

Parameters:

  • value (int) –

    Value to delete

__eq__

__eq__(compare_list: list[int] | VecUIntList) -> bool

Compare two list

Parameters:

  • compare_list (list[int] | VecUIntList) –

    List to compare

Returns:

  • bool

    Lists are equal state

__getitem__

__getitem__(index: int) -> int

Get a list item

Parameters:

  • index (int) –

    Index of the item

Returns:

  • int

    Value for the index

__init__ overloaded

__init__()

Initialize

__init__(valueList: list)

Constructor with an initializer list

Parameters:

  • valueList (list) –

    Value list

__iter__

__iter__() -> Iterator

List iterator

Returns:

  • Iterator

    List iterator

__len__

__len__() -> int

Get the list length

Returns:

  • int

    Length of the list

__repr__

__repr__() -> str

Create a string from the values

Returns:

  • str

    String

__setitem__

__setitem__(index: int | slice, value: int)

Set a list item

Parameters:

  • index (int | slice) –

    Index of the item

  • value (int) –

    Value to item

append

append(value: int)

Append a list item

Parameters:

  • value (int) –

    Value to append

extend

extend(iterable: list[int] | VecUIntList)

Add the items from an iterable to the end of the list

Parameters:

  • iterable (list[int] | VecUIntList) –

    Iterable to add