Skip to content

FixtureSlideProperties

Canonical path: NemAll_Python_Precast.FixtureSlideProperties

FixtureSlideProperties class

Methods:

Attributes:

EndScaleRange property

EndScaleRange: None

Property for end reference scale of slide Value type: float

:type: None

OffsetOfReferencePoint1 property

OffsetOfReferencePoint1: None

Property for first offset value to reference point Value type: Vector3D

:type: None

OffsetOfReferencePoint2 property

OffsetOfReferencePoint2: None

Property for second offset value to reference point Value type: Vector3D

:type: None

ReferencePoint property

ReferencePoint: None

Property for reference point Value type: Point3D

:type: None

ResizeSettingVx property

ResizeSettingVx: None

Property for resize setting for x direction Value type: eCombinationType

:type: None

ResizeSettingVy property

ResizeSettingVy: None

Property for resize setting for y direction Value type: eCombinationType

:type: None

ResizeSettingVz property

ResizeSettingVz: None

Property for resize setting for z direction Value type: eCombinationType

:type: None

StartScaleRange property

StartScaleRange: None

Property for start reference scale of slide Value type: float

:type: None

Type property

Type: None

Property for type of slide Value type: eSlideType

:type: None

ViewType property

ViewType: None

Property for view type of slide Value type: eSlideViewType

:type: None

VisibilityGeo2D property

VisibilityGeo2D: None

Property for geometry 2D visibility of slide Value type: bool

:type: None

VisibilityGeo3D property

VisibilityGeo3D: None

Property for geometry 3D visibility of slide Value type: bool

:type: None

VisibilityLayerA property

VisibilityLayerA: None

Property for layer A visibility of slide Value type: bool

:type: None

VisibilityLayerB property

VisibilityLayerB: None

Property for layer B visibility of slide Value type: bool

:type: None

VisibilityLayerC property

VisibilityLayerC: None

Property for layer C visibility of slide Value type: bool

:type: None

__eq__

__eq__(prop: FixtureSlideProperties) -> bool

equal operator

Parameters:

Returns:

  • bool

    true if they are equal, false otherwise

__init__

__init__()

Initialize

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string