Skip to content

Cone3D

Canonical path: NemAll_Python_Geometry.Cone3D

3D cone

Methods:

Attributes:

  • Apex (None) –

    Get and set the apex property

  • LocalPlacement (None) –

    Get and set the local placement property

  • MajorRadius (None) –

    Get and set the major radius property

  • MinorRadius (None) –

    Get and set the minor radius property

Apex property

Apex: None

Get and set the apex property

:type: None

LocalPlacement property

LocalPlacement: None

Get and set the local placement property

:type: None

MajorRadius property

MajorRadius: None

Get and set the major radius property

:type: None

MinorRadius property

MinorRadius: None

Get and set the minor radius property

:type: None

GetApex

GetApex() -> Point3D

Get Apex of the Cone in the local coordinate system

Returns:

GetApexParent

GetApexParent() -> Point3D

Get Apex of the Cone in the parent coordinate system

Returns:

GetCenter

GetCenter() -> Point3D

Get Center of the Cone

Returns:

GetHeight

GetHeight() -> float

Get Height of the Cone

Returns:

  • float

    Reference to Height of the Cone.

GetLocalPlacement

GetLocalPlacement() -> AxisPlacement3D

Get Local Placement

Returns:

GetMajorRadius

GetMajorRadius() -> float

Get Major Radius of the Cone

Returns:

  • float

    Reference to MajorRadius.

GetMinMax

GetMinMax() -> MinMax3D

Get MinMax of the Cone

Returns:

  • MinMax3D

    Reference to MinMax of the Cone.

GetMinorRadius

GetMinorRadius() -> float

Get Minor Radius of the Cone

Returns:

  • float

    Reference to MinorRadius.

GetXAxis

GetXAxis() -> Vector3D

Get X-Axis of the placement of the Cone

Returns:

GetZAxis

GetZAxis() -> Vector3D

Get Z - axis of the placement of the Cone

Returns:

IsCircular

IsCircular() -> bool

Circularity check for the Cone

Returns:

  • bool

    true/false

IsOblique

IsOblique() -> bool

Perpendicularity check for the Cone

Returns:

  • bool

    true/false

IsValid

IsValid() -> bool

Validity check for the Cone

Returns:

  • bool

    true/false

SetApex

SetApex(apex: Point3D)

Set Apex in the local coordinate system

Parameters:

SetApexParent

SetApexParent(apex: Point3D)

Set Apex in the parent coordinate system

Parameters:

SetCenter

SetCenter(center: Point3D)

Set center

Parameters:

SetHeight

SetHeight(arg2: float)

Set Height of the Cone

Parameters:

  • height

    New height.

SetLocalPlacement

SetLocalPlacement(placement: AxisPlacement3D)

Set Local Placement.

Parameters:

SetMajorRadius

SetMajorRadius(arg2: float)

Set Major Radius of the Cone

Parameters:

  • radius

    New major radius.

SetMinorRadius

SetMinorRadius(arg2: float)

Set Minor Radius of the Cone

Parameters:

  • radius

    New minor radius.

__eq__

__eq__(cone: Cone3D) -> object

Comparison of cones without tolerance.

Be careful, this method work without tolerance!

Parameters:

  • cone (Cone3D) –

    Compared cone.

Returns:

  • object

    True when cones are equal, otherwise false.

__init__ overloaded

__init__()

Initialize

__init__(cone: Cone3D)

Copy constructor.

Parameters:

  • cone (Cone3D) –

    Cone which will be copied.

__init__(
    refPlacement: AxisPlacement3D,
    radiusMajor: float,
    radiusMinor: float,
    apex: Point3D,
)

Constructor.

Height of the Cone is z-coordinate of the Apex.

Parameters:

  • refPlacement (AxisPlacement3D) –

    Local Placement of the Cone.

  • radiusMajor (float) –

    Major radius of the Cone.

  • radiusMinor (float) –

    Minor radius of the Cone.

  • apex (Point3D) –

    Apex of the Cone

__init__(radiusMajor: float, radiusMinor: float, apex: Point3D)

Constructor.

Height of the Cone is z-coordinate of the Apex.

Parameters:

  • radiusMajor (float) –

    Major radius of the Cone.

  • radiusMinor (float) –

    Minor radius of the Cone.

  • apex (Point3D) –

    Apex of the Cone

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string