Skip to content

ElementAdapterType

Canonical path: NemAll_Python_IFW_ElementAdapter.ElementAdapterType

Implementation of the element type

Methods:

Attributes:

  • IsVisible (bool) –

    Get the visible state of the element type

IsVisible property writable

IsVisible: bool

Get the visible state of the element type

GetDisplayName

GetDisplayName() -> str

Get the display name of the element

Returns:

  • str

    Display name

GetGuid

GetGuid() -> GUID

Get the GUID

Returns:

  • GUID

    GUID of the element type

GetModelType

GetModelType() -> GUID

Get the model type

Returns:

  • GUID

    Model type

GetTypeName

GetTypeName() -> str

Get the type name of the element

Returns:

  • str

    Type name of the element

GetZoomState

GetZoomState() -> object

Get the zoom state of the element type

Returns:

  • object

    Zoom state

Is3DElement

Is3DElement() -> bool

Get the 3D element state

Returns:

  • bool

    Element has 3D geometry: true/false

IsInfoFromParent

IsInfoFromParent() -> bool

Get the element state for the element info

Returns:

  • bool

    Use the element info from the parent element: true/false

__eq__

__eq__(guid: GUID) -> bool

Equal operator

Parameters:

  • guid (GUID) –

    Type to compare

Returns:

  • bool

    Types are equal: true/false

__ne__

__ne__(guid: GUID) -> bool

Not equal operator

Parameters:

  • guid (GUID) –

    Type to compare

Returns:

  • bool

    Types are equal: true/false