Skip to content

VisibleService

Canonical path: NemAll_Python_IFW_Input.VisibleService

Methods:

ShowAllElements staticmethod

ShowAllElements()

Show all elements

ShowElement staticmethod

ShowElement(eleList: BaseElementAdapter, bShow: bool, bForceDraw: bool)

Show/hide the element

Parameters:

  • eleList (BaseElementAdapter) –

    Element list as BaseElementAdapterList

  • bShow (bool) –

    Show / Hide = true/false

  • bForceDraw (bool) –

    Force the draw state

ShowElements staticmethod

ShowElements(eleList: BaseElementAdapterList, bShow: bool)

Show/hide the elements

Parameters:

  • eleList (BaseElementAdapterList) –

    Element list as BaseElementAdapterList

  • bShow (bool) –

    Show / Hide = true/false