Skip to content

ePolygonNormalizeType

Canonical path: NemAll_Python_Geometry.ePolygonNormalizeType

Bases: Enum

type of Polygon2D normalization

map kenn0 to an enum, see kgNormPoly

DEFAULT_NORM_TYPE : without special effects SIDEFACE_NORM_TYPE : side faces or Leisten included HATCHING_MEASUR_NORM_TYPE: 'hatching' only for measuring area HATCHING_NORM_TYPE : 'hatching' for going on with work STARTPOINT_NORM_TYPE : like 0 and additionally look for start point

DEFAULT_NORM_TYPE class-attribute instance-attribute

DEFAULT_NORM_TYPE = 0

HATCHING_MEASUR_NORM_TYPE class-attribute instance-attribute

HATCHING_MEASUR_NORM_TYPE = 2

HATCHING_NORM_TYPE class-attribute instance-attribute

HATCHING_NORM_TYPE = 3

SIDEFACE_NORM_TYPE class-attribute instance-attribute

SIDEFACE_NORM_TYPE = 1

STARTPOINT_NORM_TYPE class-attribute instance-attribute

STARTPOINT_NORM_TYPE = 4
Placeholder