Skip to content

MacroElement

Canonical path: NemAll_Python_BasisElements.MacroElement

Bases: BasisElement, AllplanElement

Representation of the macro definition (smart symbol) in Allplan

Methods:

GetAttributesForSubElementInStrucutredContainer

GetAttributesForSubElementInStrucutredContainer(sub_element_id: UUID) -> object

Get attributes to sub element in StructuredContainer

Parameters:

  • sub_element_id (UUID) –

    sub element id

Returns:

  • object

    AttributeSet

GetHash

GetHash() -> str

Get the hash value

Returns:

  • str

    Hash value

GetMacroProperties

GetMacroProperties() -> MacroProperties

Get the Macro properties

Returns:

GetSlideList

GetSlideList() -> list

Get the slide object list

Returns:

  • list

    Slide object list

SetAttributesForSubElementInStrucutredContainer

SetAttributesForSubElementInStrucutredContainer(
    attributeContainer: object, sub_element_id: UUID
)

Set attributes to sub element in StructuredContainer

Parameters:

  • attributeContainer (object) –

    attrib set

  • sub_element_id (UUID) –

    sub element id

SetHash

SetHash(hash: str)

Set the hash value

Parameters:

  • hash (str) –

    Hash value

SetMacroProperties

SetMacroProperties(MacroProp: MacroProperties)

Set the Macro properties

Parameters:

__init__ overloaded

__init__()

Initialize

__init__(macroProp: MacroProperties, slideList: list)

Constructor

Parameters:

  • macroProp (MacroProperties) –

    Macro properties

  • slideList (list) –

    Slide list of macro definition

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string