Skip to content

Plane3D

Canonical path: NemAll_Python_Geometry.Plane3D

Representation class for 3D plane.

Methods:

  • CalcPlaneVectors

    Calc X and Y axis vectors for plane

  • GetPoint

    Get 3D Plane reference point

  • GetTransformationMatrix

    Get transformation matrix for given plane 3D

  • GetVector

    Get the Normal Vector

  • Set

    Initialize Plane from point and vector

  • SetPoint

    Set reference point

  • SetVector

    Set the Normal Vector

  • __eq__

    Comparison of planes without tolerance.

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __mul__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __repr__

    Convert to string

Attributes:

Point property writable

Point: Point3D

Get 3D Plane reference point

Vector property writable

Vector: Vector3D

Get the Normal Vector

CalcPlaneVectors

CalcPlaneVectors() -> tuple[Vector3D, Vector3D]

Calc X and Y axis vectors for plane

Returns:

GetPoint

GetPoint() -> Point3D

Get 3D Plane reference point

Returns:

GetTransformationMatrix

GetTransformationMatrix() -> Matrix3D

Get transformation matrix for given plane 3D

Returns:

GetVector

GetVector() -> Vector3D

Get the Normal Vector

Returns:

Set

Set(point: Point3D, normalVector: Vector3D)

Initialize Plane from point and vector

Parameters:

SetPoint

SetPoint(point: Point3D)

Set reference point

Parameters:

SetVector

SetVector(vec: Vector3D)

Set the Normal Vector

Parameters:

__eq__

__eq__(plane: Plane3D) -> object

Comparison of planes without tolerance.

Be careful, this method work without tolerance!

Parameters:

  • plane (Plane3D) –

    Compared plane.

Returns:

  • object

    True when planes are equal, otherwise false.

__init__ overloaded

__init__()

Initialize

__init__(plane: Plane3D)

Copy constructor

Parameters:

  • plane (Plane3D) –

    Plane which will be copied.

__init__(point: Point3D, normalVector: Vector3D)

Constructor

Create 3D Plane with given point and vector

Parameters:

  • point (Point3D) –

    Init point of the plane.

  • normalVector (Vector3D) –

    Init vector of the plane.

__init__(point1: Point3D, point2: Point3D, point3: Point3D)

Constructor

Create 3D Plane from three points which lies on this plane. If plane can not be computed, then constructor throw geometry exception 'Incorrect parameters'.

Parameters:

  • point1 (Point3D) –

    1st point on the plane.

  • point2 (Point3D) –

    2nd point on the plane.

  • point3 (Point3D) –

    3rd point on the plane.

__init__(axis: Axis3D)

Create a plane from a 3D axis

Parameters:

__mul__ overloaded

__mul__(matrix: Matrix2D) -> Plane3D

2D matrix transformation.

Parameters:

  • matrix (Matrix2D) –

    2D transformation Matrix

Returns:

  • Plane3D

    Copy of transformed 3D plane.

__mul__(matrix: Matrix3D) -> Plane3D

3D matrix transformation.

Parameters:

  • matrix (Matrix3D) –

    3D transformation Matrix

Returns:

  • Plane3D

    Copy of transformed 3D plane.

__repr__

__repr__() -> str

Convert to string