Skip to content

eAttibuteReadState

Canonical path: NemAll_Python_BaseElements.eAttibuteReadState

Bases: Enum

Enumeration of possible attribute reading modes of the ElementAttributeService

Attributes:

DoNotRead class-attribute instance-attribute

DoNotRead = 2

Do not read any attributes

ReadAll class-attribute instance-attribute

ReadAll = 1

Read all attributes, without computed ones

ReadAllAndComputable class-attribute instance-attribute

ReadAllAndComputable = 3

Read all the attributes, also the computed ones

ReadWithoutGeometry class-attribute instance-attribute

ReadWithoutGeometry = 0

Read all non-geometrical attributes