Skip to content

Line3DList

Canonical path: NemAll_Python_Geometry.Line3DList

Methods:

__contains__

__contains__(value: Line3D) -> bool

Check for a value in the list

Parameters:

  • value (Line3D) –

    Value to check

Returns:

  • bool

    State for value is in the list

__delitem__

__delitem__(value: Line3D)

Delete a list item

Parameters:

  • value (Line3D) –

    Value to delete

__eq__

__eq__(compare_list: Line3DList) -> bool

Compare two lists

__getitem__

__getitem__(index: int) -> Line3D

Get a list item

Parameters:

  • index (int) –

    Index of the item

Returns:

  • Line3D

    Value for the index

__init__

__init__()

Initialize

__iter__

__iter__() -> Iterator

List iterator

Returns:

  • Iterator

    List iterator

__len__

__len__() -> int

Get the list length

Returns:

  • int

    Length of the list

__repr__

__repr__() -> str

Create a string from the elements of the list

__setitem__

__setitem__(index: int | slice, value: Line3D)

Set a list item

Parameters:

  • index (int | slice) –

    Index of the item

  • value (Line3D) –

    Value to item

append

append(value: Line3D)

Append a list item

Parameters:

  • value (Line3D) –

    Value to append

extend

extend(iterable: Line3DList)

Add the items from an iterable to the end of the list

Parameters: