Skip to content

AllplanElement

Canonical path: NemAll_Python_ArchElements.AllplanElement

Implementation of the Allplan element

Methods:

Attributes:

Attributes property writable

Attributes: object

Get the attributes object

CommonProperties property writable

CommonProperties: CommonProperties

Get the common properties

GeometryObject property writable

GeometryObject: object

Get the geometry object

LabelElements property writable

LabelElements: list

Get the label elements

GetAttributes

GetAttributes() -> object

Get the attributes object

Returns:

  • object

    Attributes object

GetBaseElementAdapter

GetBaseElementAdapter() -> BaseElementAdapter

Get the model element

Returns:

GetCommonProperties

GetCommonProperties() -> CommonProperties

Get the common properties

Returns:

GetGeometryObject

GetGeometryObject() -> object

Get the geometry object

Returns:

  • object

    Geometry object

GetLabelElements

GetLabelElements() -> list

Get the label elements

Returns:

  • list

    LabelElements

GetSubElementID

GetSubElementID() -> type

Get the SubElementID

Returns:

  • type

    SubElementID

SetAttributes

SetAttributes(attributeContainer: object)

Set the attributes object

Parameters:

  • attributeContainer (object) –

    Attributes object

SetCommonProperties

SetCommonProperties(commonProp: CommonProperties)

Set the common properties

Parameters:

SetDockingPointsKey

SetDockingPointsKey(dockingPointsKey: str)

Set the docking points key

Parameters:

  • dockingPointsKey (str) –

    Docking points key

SetGeometryObject

SetGeometryObject(geoObject: object)

Set the geometry object

Parameters:

  • geoObject (object) –

    Geometry object

SetLabelElements

SetLabelElements(labelElements: list)

Set the label elements

Parameters:

  • labelElements (list) –

    Label elements