Skip to content

InputAngleSettings

Canonical path: NemAll_Python_AllplanSettings.InputAngleSettings

Utility containing functions to control the Allplan settings related to the input angle

Methods:

GetAngleInputUnit staticmethod

GetAngleInputUnit() -> eAngleGradientUnit

Gets the current setting for unit of angle

Returns:

GetGradientInputUnit staticmethod

GetGradientInputUnit() -> eAngleGradientUnit

Gets the current setting for Inclination as. If it's set to Angle, the result will be the current Unit of angle setting

Returns:

GetProjectAngle staticmethod

GetProjectAngle(noCache: bool = False) -> float

Get the project angle

Parameters:

  • noCache (bool, default: False ) –

    Use no cache: true/false

Returns:

  • float

    Project angle

GetSystemAngle staticmethod

GetSystemAngle() -> float

Get the system angle (rotation angle of the cursor)

Returns:

  • float

    System angle in radian

SetProjectAngle staticmethod

SetProjectAngle(angle: float)

Set the project angle

Parameters:

  • angle (float) –

    Project angle

SetSystemAngle staticmethod

SetSystemAngle(angle: float)

Set the system angle

Parameters:

  • angle (float) –

    New system angle