Skip to content

Symbol2DProperties

Canonical path: NemAll_Python_BasisElements.Symbol2DProperties

Properties of the point symbol

Methods:

Attributes:

Height property

Height: None

Symbol height

IsScaleDependent property

IsScaleDependent: None

Whether the symbol should be scale dependent

PrimaryPointNumber property

PrimaryPointNumber: None

Primary point number

RotationAngle property

RotationAngle: None

Rotation angle

SecondaryPointNumber property

SecondaryPointNumber: None

Secondary point number

SymbolID property

SymbolID: None

Symbol ID

Width property

Width: None

Symbol width

__eq__

__eq__(prop: Symbol2DProperties) -> bool

equal operator

Parameters:

Returns:

  • bool

    true if they are equal, false otherwise

__init__

__init__()

Initialize

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string