Skip to content

VecGUIDList

Canonical path: NemAll_Python_Utility.VecGUIDList

Methods:

__contains__

__contains__(value: GUID) -> bool

Check for a value in the list

Parameters:

  • value (GUID) –

    Value to check

Returns:

  • bool

    State for value is in the list

__delitem__

__delitem__(value: GUID)

Delete a list item

Parameters:

  • value (GUID) –

    Value to delete

__eq__

__eq__(compare_list: VecGUIDList) -> bool

Compare two list

Parameters:

Returns:

  • bool

    Lists are equal state

__getitem__

__getitem__(index: int) -> GUID

Get a list item

Parameters:

  • index (int) –

    Index of the item

Returns:

  • GUID

    Value for the index

__init__

__init__()

Initialize

__iter__

__iter__() -> Iterator

List iterator

Returns:

  • Iterator

    List iterator

__len__

__len__() -> int

Get the list length

Returns:

  • int

    Length of the list

__setitem__

__setitem__(index: int | slice, value: GUID)

Set a list item

Parameters:

  • index (int | slice) –

    Index of the item

  • value (GUID) –

    Value to item

append

append(value: GUID)

Append a list item

Parameters:

  • value (GUID) –

    Value to append

extend

extend(iterable: VecGUIDList)

Add the items from an iterable to the end of the list

Parameters: