Skip to content

SlabProperties

Canonical path: NemAll_Python_ArchElements.SlabProperties

Bases: ArchBaseProperties

Implementation of the Slab properties

Methods:

  • SetAttribute

    Set the attribute

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

SetAttribute

SetAttribute(attrib: object)

Set the attribute

Parameters:

  • attrib (object) –

    Attribute

__init__ overloaded

__init__()

Initialize

__init__(slabProp: SlabProperties)

Copy constructor

Parameters: