Skip to content

PythonWpfPalette

Canonical path: NemAll_Python_Palette.PythonWpfPalette

Implementation of the WPF palette for python

Methods:

Close

Close() -> str

Close the palette

Returns:

  • str

    Name of the active page

EnableControl

EnableControl(name: str, iPage: int, bEnabled: bool)

Enable/disable a control

Parameters:

  • name (str) –

    Name of the control

  • iPage (int) –

    Page index

  • bEnabled (bool) –

    Enabled: true/false

GetPythonWpfPaletteBuilder

GetPythonWpfPaletteBuilder() -> PythonWpfPaletteBuilder

Get the palette builder

Returns:

Open

Open(
    title: str,
    partName: str,
    dataColumnWidth: int,
    showCloseButton: bool,
    showFavoriteButtons: bool,
    doc: DocumentAdapter,
    activePageText: str,
)

Open the palette

Parameters:

  • title (str) –

    Title

  • partName (str) –

    Name of the PythonPart

  • dataColumnWidth (int) –

    Width of the data column

  • showCloseButton (bool) –

    Show the close button state

  • showFavoriteButtons (bool) –

    Show the favorites button state

  • doc (DocumentAdapter) –

    Document

  • activePageText (str) –

    Page text of the active page

Reset

Reset(clearOnlyPages: bool = False)

Reset the palette for a full refresh

Parameters:

  • clearOnlyPages (bool, default: False ) –

    Reset only pages, keep other dialog data settings

UpdateDialogData

UpdateDialogData(activePage: int)

Refresh palette with current dialog data

Parameters:

  • activePage (int) –

    Index of the active page: (-1 = use current)

__init__

__init__()

Constructor

__repr__

__repr__() -> str

Convert to string