Skip to content

Attributes

Canonical path: NemAll_Python_BaseElements.Attributes

Attributes class

Methods:

Attributes:

AttributeSets property

AttributeSets: None

Property for attribute set vector

:type: None

GetAttributeSets

GetAttributeSets() -> list

Get the AttributeSet vector

Returns:

  • list

    Attribute value

SetAttributeSets

SetAttributeSets(sets: list)

Set the AttributeSet vector

Parameters:

  • sets (list) –

    AttributeSet vector

__eq__

__eq__(props: Attributes) -> bool

Compare operator

Parameters:

Returns:

  • bool

    Properties a equal: true/false

__init__ overloaded

__init__()

Initialize

__init__(elements: list)

Constructor

Parameters:

  • elements (list) –

    Attribute set element list

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string