Skip to content

ApproximationSettings

Canonical path: NemAll_Python_Geometry.ApproximationSettings

Class holding approximation options.

Methods:

GetDensity

GetDensity() -> float

Get Density value

Returns:

  • float

    density value

GetMaxAngle

GetMaxAngle() -> Angle

Get Maximal Angle value

Returns:

  • Angle

    maximal angle value

GetMaxDistance

GetMaxDistance() -> float

Get MaxDistance value

Returns:

  • float

    const Reference to MaxDistance value

GetMaxLength

GetMaxLength() -> float

Get MaxLength value

Returns:

  • float

    const Reference to MaxLength value

GetMinLength

GetMinLength() -> float

Get Minimal Length value

Returns:

  • float

    minimal length value

GetSegmentation

GetSegmentation() -> int

Get Segmentation value

Returns:

  • int

    const Reference to Segmentation value

GetType

Get Type of the settings

Returns:

IsBRepTesselation

IsBRepTesselation() -> bool

Check whether the type of the settings is ASET_BREP_TESSELATION

Returns:

  • bool

    true/false.

IsMaxDistance

IsMaxDistance() -> bool

Check whether the type of the settings is ASET_MAX_DISTANCE

Returns:

  • bool

    true/false.

IsMaxLength

IsMaxLength() -> bool

Check whether the type of the settings is ASET_MAX_LENGTH

Returns:

  • bool

    true/false.

IsSegmentation

IsSegmentation() -> bool

Check whether the type of the settings is ASET_SEGMENTATION

Returns:

  • bool

    true/false.

SetBRepTesselation

SetBRepTesselation(
    density: float, maxAngle: Angle, minLength: float, maxLength: float
)

Set all settings for BRep3D tesselation.

Parameters:

  • density (float) –

    new density value.

  • maxAngle (Angle) –

    new maximal edge length value.

  • minLength (float) –

    new minimal edge length value.

  • maxLength (float) –

    new maximal angle value.

SetMaxDistance

SetMaxDistance(maxDistance: float)

Set MaxDistance value.

Parameters:

  • maxDistance (float) –

    new MaxDistance value.

SetMaxLength

SetMaxLength(maxLength: float)

Set MaxLength value.

Parameters:

  • maxLength (float) –

    new MaxLength value.

SetSegmentation

SetSegmentation(segmentation: int)

Set Segmentation.

Parameters:

  • segmentation (int) –

    new Segmentation value.

__eq__

__eq__(right: ApproximationSettings) -> bool

Operator ==

Parameters:

Returns:

  • bool

    true if settings are equal

__init__ overloaded

__init__(
    oType: eApproximationSettingsType = ASET_SEGMENTATION, value: float = 30.0
)

Default constructor.

Other members will be set to 0. Types can be found in GeometryEnums.h

Parameters:

__init__(options: ApproximationSettings)

Copy constructor.

Parameters:

__ne__

__ne__(right: ApproximationSettings) -> bool

Operator !=

Parameters:

Returns:

  • bool

    true if settings are NOT equal