Skip to content

BitmapDefinition

Canonical path: NemAll_Python_BasisElements.BitmapDefinition

Methods:

Attributes:

AbsolutePath property writable

AbsolutePath: str

Absolute path of the bitmap

RelativeName property writable

RelativeName: str

Relative name of the bitmap

Create staticmethod

Create(bitmapName: str) -> BitmapDefinition

Create a bitmap definition

Returns:

Parameters:

  • bitmapName (str) –

    Path and name of the bitmap

Dump

Dump(deep: bool)

Dump the bitmap definition

Parameters:

  • deep (bool) –

    True for a deep dump

GetBitmapName

GetBitmapName() -> str

Get the name

Returns:

  • str

    Name

GetHeight

GetHeight() -> int

Get bitmap height

Returns:

  • int

    height in pixels

GetPixel

GetPixel(x: int, y: int) -> int

Get the color of a specific pixel

Parameters:

  • x (int) –

    horizontal position

  • y (int) –

    vertical position

Returns:

  • int

    Color as ARGB

GetWidth

GetWidth() -> int

Get bitmap width

Returns:

  • int

    Width in pixels

IsHDRI

IsHDRI() -> bool

Is High Dynamic Range Image

Returns:

  • bool

    Bitmap is a HDR image

LoadBitmap

LoadBitmap() -> bool

Load bitmap

Returns:

  • bool

    True, when loading was successful

setName

setName(resourceName: str)

Set the name of the bitmap

Parameters:

  • resourceName (str) –

    name to assign