Skip to content

HandleService

Canonical path: NemAll_Python_IFW_Input.HandleService

Implementation of the handle service

Methods:

AddHandles

AddHandles(
    doc: DocumentAdapter,
    handlePropList: object,
    insertionMat: Matrix3D,
    assoRefObj: object,
)

Add the handles

Parameters:

  • doc (DocumentAdapter) –

    Document

  • handlePropList (object) –

    Handle properties list

  • insertionMat (Matrix3D) –

    Transformation matrix

  • assoRefObj (object) –

    Reference element for the drawing inside the associative views

DeleteToolTipText

DeleteToolTipText()

Delete the tool tip text

DrawHandles

DrawHandles()

Draw the handles

RemoveHandles

RemoveHandles()

Remove the handles

SelectHandle

SelectHandle(
    pnt: Point2D, viewProj: ViewWorldProjection
) -> tuple[int, Matrix3D]

Select a handle

Parameters:

Returns:

  • tuple[int, Matrix3D]

    Handle index (-1 = no selection) , associative view to world matrix

ShowToolTipText

ShowToolTipText(text: str)

Show the tool tip text

Parameters:

  • text (str) –

    Text

__init__

__init__()

Initialize