Skip to content

PolylineInput

Canonical path: NemAll_Python_IFW_Input.PolylineInput

Bases: CoordinateInput, InputViewDocumentData

Implementation of the polyline input

Methods:

ExecuteInput

ExecuteInput(mouseMsg: int, pnt: Point2D, pMsgInfo: AddMsgInfo) -> int

Execute the input

Parameters:

  • mouseMsg (int) –

    Mouse message

  • pnt (Point2D) –

    View input point

  • pMsgInfo (AddMsgInfo) –

    Additional message info

Returns:

  • int

    execution state

GetPolyline

GetPolyline() -> Polyline3D

get the final polyline

Returns:

GetPreviewPolyline

GetPreviewPolyline() -> Polyline3D

get the preview polyline

Returns:

StartNewInput

StartNewInput()

Start new input

__init__

__init__(coordInput: CoordinateInput, bZCoord: bool)

Default constructor

After constructing the object, the line input toolbar is shown in the Allplan UI

Parameters:

  • coordInput (CoordinateInput) –

    Coordinate input object

  • bZCoord (bool) –

    True will show the Z-coordinate input control, False will hide it. False will not prevent from input of a 3D polyline!