Skip to content

PrecastElementProperties

Canonical path: NemAll_Python_Precast.PrecastElementProperties

PrecastElementProperties class

Methods:

Attributes:

CreateLabeling property

CreateLabeling: None

Property for CreateLabeling Value type: bool

:type: None

DimensionCross property

DimensionCross: None

Property for DimensionCross Value type: float

:type: None

DimensionSpan property

DimensionSpan: None

Property for DimensionSpan Value type: float

:type: None

DimensionViewing property

DimensionViewing: None

Property for DimensionViewing Value type: float

:type: None

ElemTypeAttribut property

ElemTypeAttribut: None

Property for ElemTypeAttribut Value type: str

:type: None

ElementType property

ElementType: None

Property for ElementType Value type: int

:type: None

ElementTypeCatGUID property

ElementTypeCatGUID: None

Property for ElementTypeCatGUID Value type: GUID

:type: None

Factory property

Factory: None

Property for Factory Value type: str

:type: None

FactoryCatAddressOffset property

FactoryCatAddressOffset: None

Property for FactoryCatAddressOffset Value type: int

:type: None

LabelingTextRefPoint property

LabelingTextRefPoint: None

Property for LabelingTextRefPoint Value type: int

:type: None

Layers property

Layers: None

Property for Layers Value type: list

:type: None

ManualDimensions property

ManualDimensions: None

Property for ManualDimensions Value type: bool

:type: None

Norm property

Norm: None

Property for Norm Value type: str

:type: None

NormCatAddressOffset property

NormCatAddressOffset: None

Property for NormCatAddressOffset Value type: int

:type: None

PieceFactor property

PieceFactor: None

Property for PieceFactor Value type: int

:type: None

PosNr property

PosNr: None

Property for PosNr Value type: int

:type: None

PosNrText property

PosNrText: None

Property for PosNrText Value type: str

:type: None

ReferencePoint property

ReferencePoint: None

Property for ReferencePoint Value type: Point3D

:type: None

SpanDirection property

SpanDirection: None

Property for SpanDirection Value type: Point3D

:type: None

ViewDirection property

ViewDirection: None

Property for ViewDirection Value type: Point3D

:type: None

GetPrecastElementTypeFromIdx

GetPrecastElementTypeFromIdx(arg2: int) -> str

Get the name of the PrecastElementType from Cat Idx

Returns:

  • str

    PrecastElementType Cat Name

SetElementTypeCatalogGUID_from_Name

SetElementTypeCatalogGUID_from_Name(arg2: str) -> GUID

Set the elementTypeCatGUID

Returns:

  • GUID

    elementTypeCatGUID

SetFactoryCatalogAddressOffset

SetFactoryCatalogAddressOffset(arg2: str) -> int

Set the factoryCatAddressOffset

Returns:

  • int

    factoryCatAddressOffset

SetNormCatalogAddressOffset

SetNormCatalogAddressOffset(arg2: str) -> int

Set the normCatAddressOffset

Returns:

  • int

    normCatAddressOffset

__eq__

__eq__(prop: PrecastElementProperties) -> bool

equal operator

Parameters:

Returns:

  • bool

    true if they are equal, false otherwise

__init__

__init__()

Initialize

__repr__

__repr__() -> str

Convert to string