Skip to content

eProjectionType

Canonical path: NemAll_Python_IFW_Input.eProjectionType

Bases: Enum

Projection type of the view

Attributes:

EAST_VIEW class-attribute instance-attribute

EAST_VIEW = 3

FREE_ONLY_3D class-attribute instance-attribute

FREE_ONLY_3D = 9

FREE_VIEW class-attribute instance-attribute

FREE_VIEW = 0

GROUND_PLAN class-attribute instance-attribute

GROUND_PLAN = 1

NORTH_EAST_VIEW class-attribute instance-attribute

NORTH_EAST_VIEW = 5

NORTH_VIEW class-attribute instance-attribute

NORTH_VIEW = 2

NORTH_WEST_VIEW class-attribute instance-attribute

NORTH_WEST_VIEW = 6

SOUTH_EAST_VIEW class-attribute instance-attribute

SOUTH_EAST_VIEW = 8

SOUTH_VIEW class-attribute instance-attribute

SOUTH_VIEW = -2

SOUTH_WEST_VIEW class-attribute instance-attribute

SOUTH_WEST_VIEW = 7

WEST_VIEW class-attribute instance-attribute

WEST_VIEW = -3

WORKING_PLANE_VIEW class-attribute instance-attribute

WORKING_PLANE_VIEW = 4