Skip to content

Clothoid2DList

Canonical path: NemAll_Python_Geometry.Clothoid2DList

Methods:

__contains__

__contains__(value: Clothoid2D) -> bool

Check for a value in the list

Parameters:

Returns:

  • bool

    State for value is in the list

__delitem__

__delitem__(value: Clothoid2D)

Delete a list item

Parameters:

__getitem__

__getitem__(index: int) -> Clothoid2D

Get a list item

Parameters:

  • index (int) –

    Index of the item

Returns:

__init__

__init__()

Initialize

__iter__

__iter__() -> Iterator

List iterator

Returns:

  • Iterator

    List iterator

__len__

__len__() -> int

Get the list length

Returns:

  • int

    Length of the list

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string

__setitem__

__setitem__(index: int | slice, value: Clothoid2D)

Set a list item

Parameters:

  • index (int | slice) –

    Index of the item

  • value (Clothoid2D) –

    Value to item

append

append(value: Clothoid2D)

Append a list item

Parameters:

extend

extend(iterable: Clothoid2DList)

Add the items from an iterable to the end of the list

Parameters: