Skip to content

TextureMapping

Canonical path: NemAll_Python_BasisElements.TextureMapping

Texture mapping property class

Methods:

  • FromSurfaceMapping

    Get the properties from the surface mapping object

  • __eq__

    Compare operator

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __repr__

    Convert to string

Attributes:

MappingAngle property writable

MappingAngle: float

Get mapping angle

MappingType property writable

MappingType: eMappingType

Get mapping type

PhongAngle property writable

PhongAngle: float

Get angle for Phong light model

ReferenceEdge property writable

ReferenceEdge: int

Get reference edge

ReferenceFace property writable

ReferenceFace: int

Get reference face

UVCoordinates property writable

UVCoordinates: list[float]

Get UV texture mapping coordinates

UValueForIsoLines property writable

UValueForIsoLines: int

Get U count of isolines

VValueForIsoLines property writable

VValueForIsoLines: int

Get V count of isolines

XOffset property writable

XOffset: float

Get X offset

XScale property writable

XScale: float

Get mapping X scale

YOffset property writable

YOffset: float

Get Y offset

YScale property writable

YScale: float

Get mapping Y scale

FromSurfaceMapping

FromSurfaceMapping(mapping: object)

Get the properties from the surface mapping object

Parameters:

  • mapping (object) –

    Surface mapping

__eq__

__eq__(props: TextureMapping) -> bool

Compare operator

Parameters:

Returns:

  • bool

    Properties a equal: true/false

__init__ overloaded

__init__()

Initialize

__init__(
    mappingType: TextureMappingType,
    mappingAngle: float,
    scaleX: float,
    scaleY: float,
    offsetX: float,
    offsetY: float,
    phongAngle: float,
    refFace: int,
    refEdge: int,
)

Constructor

Parameters:

  • mappingType (TextureMappingType) –

    Mapping type

  • mappingAngle (float) –

    Mapping angle

  • scaleX (float) –

    Mapping scale in X-axis

  • scaleY (float) –

    Mapping scale in Y-axis

  • offsetX (float) –

    X offset

  • offsetY (float) –

    Y offset

  • phongAngle (float) –

    Angle for Phong light model

  • refFace (int) –

    Reference face

  • refEdge (int) –

    Reference edge

__init__(
    mappingType: TextureMappingType,
    mappingAngle: float,
    scaleX: float,
    scaleY: float,
    offsetX: float,
    offsetY: float,
    phongAngle: float,
    refFace: int,
    refEdge: int,
    uvCoords: VecDoubleList,
)

Constructor

Parameters:

  • mappingType (TextureMappingType) –

    Mapping type

  • mappingAngle (float) –

    Mapping angle

  • scaleX (float) –

    Mapping scale in X-axis

  • scaleY (float) –

    Mapping scale in Y-axis

  • offsetX (float) –

    X offset

  • offsetY (float) –

    Y offset

  • phongAngle (float) –

    Angle for Phong light model

  • refFace (int) –

    Reference face

  • refEdge (int) –

    Reference edge

  • uvCoords (VecDoubleList) –

    UV coordinates

__init__(uvCoords: VecDoubleList)

Constructor, set the type to eUV

Parameters:

__init__(element: TextureMapping)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert to string