Skip to content

ProjectAttributeService

Canonical path: NemAll_Python_BaseElements.ProjectAttributeService

Utility for processing the values of project-specific attributes

This utility class provides methods for processing the project-specific attributes, such as reading or modifying the attribute values of the current project or reading all the attributes from all available projects.

Methods:

ChangeAttributeFromCurrentProject overloaded

ChangeAttributeFromCurrentProject(
    attributeNumber: int, newValue: int, doc: DocumentAdapter
)

Change a project attribute from the current file

Parameters:

  • attributeNumber (int) –

    Attribute number

  • newValue (int) –

    Attribute value

  • doc (DocumentAdapter) –

    Document

ChangeAttributeFromCurrentProject(
    attributeNumber: int, newValue: float, doc: DocumentAdapter
)

Change a project attribute from the current file

Parameters:

  • attributeNumber (int) –

    Attribute number

  • newValue (float) –

    Attribute value

  • doc (DocumentAdapter) –

    Document

ChangeAttributeFromCurrentProject(
    attributeNumber: int, newValue: str, doc: DocumentAdapter
)

Change a project attribute from the current file

Parameters:

  • attributeNumber (int) –

    Attribute number

  • newValue (str) –

    Attribute value

  • doc (DocumentAdapter) –

    Document

ChangeAttributesFromCurrentProject staticmethod

ChangeAttributesFromCurrentProject(
    attributes: list[tuple[int, int | float | str]], doc: DocumentAdapter
)

Change attributes from the current project

Parameters:

  • attributes (list[tuple[int, int | float | str]]) –

    Attributes

  • doc (DocumentAdapter) –

    Document

GetAttributesFromAllProjects staticmethod

GetAttributesFromAllProjects() -> list[tuple[int, int | float | str]]

Get the attributes from all projects

Returns:

  • list[tuple[int, int | float | str]]

    Attributes from all projects

GetAttributesFromCurrentProject staticmethod

GetAttributesFromCurrentProject() -> list[tuple[int, int | float | str]]

Get the attributes from the current project

Returns:

  • list[tuple[int, int | float | str]]

    Attributes from the current project