Skip to content

PythonPartService

Canonical path: NemAll_Python_BaseElements.PythonPartService

Utility for processing PythonParts existing in the drawing file

This utility class provides methods for processing the PythonParts, that exist in the drawing file, such as reading and modifying their parameter values.

Methods:

GetParameter staticmethod

GetParameter(ele: BaseElementAdapter) -> tuple

Get the parameter of the PythonPart

Parameters:

Returns:

  • tuple

    True, when reading was successful. False otherwise.

  • tuple

    Name of the PythonPart

  • tuple

    Parameter list

GetPlacementMatrix staticmethod

GetPlacementMatrix(ele: BaseElementAdapter) -> tuple

Get the placement matrix of the PythonPart

Parameters:

Returns:

  • tuple

    True, when reading was successful. False otherwise.

  • tuple

    Placement matrix

IsPythonPartElement staticmethod

IsPythonPartElement(ele: BaseElementAdapter) -> bool

Check for a PythonPart element

Parameters:

Returns:

  • bool

    PythonPart element state

SetParameter staticmethod

SetParameter(
    ele: BaseElementAdapter, name: str, paramList: list
) -> BaseElementAdapter

Set the parameter of the PythonPart

Parameters:

Returns: