Skip to content

ExtrudedAreaSolid3D

Canonical path: NemAll_Python_Geometry.ExtrudedAreaSolid3D

Solid created by extrusion of area by given direction vector

Methods:

Attributes:

  • Direction (None) –

    Get and set the direction as property

  • ExtrudedArea (None) –

    Get and set the extruded area as property

  • RefPoint (None) –

    Get and set the reference point as property

Direction property

Direction: None

Get and set the direction as property

:type: None

ExtrudedArea property

ExtrudedArea: None

Get and set the extruded area as property

:type: None

RefPoint property

RefPoint: None

Get and set the reference point as property

:type: None

GetDirection

GetDirection() -> Vector3D

Get direction for extrusion

Returns:

GetExtrudedArea

GetExtrudedArea() -> PolygonalArea3D

Get extruded area

Returns:

GetRefPoint

GetRefPoint() -> Point3D

Get the reference point

Returns:

IsValid

IsValid() -> bool

Check if the Solid is valid

Returns:

  • bool

    True if it is a valid solid

SetDirection

SetDirection(dir: Vector3D)

Set direction for extrusion

Parameters:

  • dir (Vector3D) –

    Vector3D const reference

SetExtrudedArea

SetExtrudedArea(area: PolygonalArea3D)

Set extruded area

Parameters:

SetRefPoint

SetRefPoint(refPoint: Point3D)

Set reference point

Parameters:

  • refPoint (Point3D) –

    New reference point

__eq__

__eq__(extrudedAreaSolid: ExtrudedAreaSolid3D) -> object

Comparison of extrudedAreaSolids without tolerance.

Be careful, this method work without tolerance!

Parameters:

Returns:

  • object

    True when extrudedAreaSolids are equal, otherwise false.

__init__ overloaded

__init__()

Initialize

__init__(solid: ExtrudedAreaSolid3D)

Copy constructor.

Parameters:

__init__(solid: Point3D, refPoint: ExtrudedAreaSolid3D)

Copy constructor.

Parameters:

__mul__

__mul__(matrix: Matrix3D) -> object

Matrix transformation

Parameters:

  • matrix (Matrix3D) –

    Transformation 3D matrix

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string