Skip to content

ClippedSweptSolid3D

Canonical path: NemAll_Python_Geometry.ClippedSweptSolid3D

Representation class for solid created by extrusion of area with borders of a plane at the bottom and a plane at the top in world z - axis direction

Methods:

Attributes:

  • BottomPlane (None) –

    Get and set the bottom plane as property

  • RefPoint (None) –

    Get and set the reference point as property

  • SweptArea (None) –

    Get and set the swept area as property

  • TopPlane (None) –

    Get and set the top plane as property

BottomPlane property

BottomPlane: None

Get and set the bottom plane as property

:type: None

RefPoint property

RefPoint: None

Get and set the reference point as property

:type: None

SweptArea property

SweptArea: None

Get and set the swept area as property

:type: None

TopPlane property

TopPlane: None

Get and set the top plane as property

:type: None

GetBottomPlane

GetBottomPlane() -> Plane3D

Get bottom clipping plane

Returns:

  • Plane3D

    Plane3D const reference

GetRefPoint

GetRefPoint() -> Point3D

Get the reference point

Returns:

GetSweptArea

GetSweptArea() -> PolygonalArea2D

Get Swept area

Returns:

GetTopPlane

GetTopPlane() -> Plane3D

Get top clipping plane

Returns:

  • Plane3D

    Plane3D const reference

IsValid

IsValid() -> bool

Check if the Solid is valid

Returns:

  • bool

    True if it is a valid solid

SetBottomPlane

SetBottomPlane(plane: Plane3D)

Set bottom clipping plane

Parameters:

  • plane (Plane3D) –

    Plane3D const reference

SetRefPoint

SetRefPoint(refPoint: Point3D)

Set reference point

Parameters:

  • refPoint (Point3D) –

    New reference point

SetSweptArea

SetSweptArea(area: PolygonalArea2D)

Set Swept area

Parameters:

SetTopPlane

SetTopPlane(plane: Plane3D)

Set top clipping plane

Parameters:

  • plane (Plane3D) –

    Plane3D const reference

__eq__

__eq__(clippedSweptSolid: ClippedSweptSolid3D) -> object

Comparison of clippedSweptSolids without tolerance.

Be careful, this method work without tolerance!

Parameters:

Returns:

  • object

    True when clippedSweptSolids are equal, otherwise false.

__init__ overloaded

__init__()

Initialize

__init__(area: PolygonalArea2D, bottom: Plane3D, top: Plane3D)

Constructor which sets swept area, bottom and top planes.

Parameters:

__init__(solid: ClippedSweptSolid3D)

Copy constructor.

Parameters:

__init__(refPoint: Point3D, solid: ClippedSweptSolid3D)

Copy constructor.

Parameters:

__mul__

__mul__(matrix: Matrix3D) -> object

Matrix transformation

Parameters:

  • matrix (Matrix3D) –

    Transformation 3D matrix

Returns:

  • object

    Transformed ClippedSweptSolid3D

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string