Skip to content

PlaneService

Canonical path: NemAll_Python_BaseElements.PlaneService

Implementation of the plane service

Methods:

CreateBRepSurfacePlane staticmethod

CreateBRepSurfacePlane(
    doc: DocumentAdapter,
    planeSurface: BRep3D,
    surfaceName: str,
    isVisible: bool,
) -> BaseElementAdapter

Create a BRep3D surface plane

Parameters:

  • doc (DocumentAdapter) –

    Document

  • planeSurface (BRep3D) –

    Plane surface

  • surfaceName (str) –

    Name of the surface

  • isVisible (bool) –

    Visible state

Returns:

CreatePolyhedronSurfacePlane staticmethod

CreatePolyhedronSurfacePlane(
    doc: DocumentAdapter,
    planeSurface: Polyhedron3D,
    surfaceName: str,
    isVisible: bool,
) -> BaseElementAdapter

Create a Polyhedron3D surface plane

Parameters:

  • doc (DocumentAdapter) –

    Document

  • planeSurface (Polyhedron3D) –

    Plane surface

  • surfaceName (str) –

    Name of the surface

  • isVisible (bool) –

    Visible state

Returns:

GetCurrentLevelModelGuid

GetCurrentLevelModelGuid() -> GUID

Get the current level model GUID of the active drawing file

Returns:

  • GUID

    Level modle GUID

__init__ overloaded

__init__()

Initialize

__init__(doc: DocumentAdapter)

Constructor

Parameters:

__init__(element: PlaneService)

Copy constructor

Parameters: