Skip to content

DoorOpeningElement

Canonical path: NemAll_Python_ArchElements.DoorOpeningElement

Bases: ArchElement, AllplanElement

Implementation of the door opening element

Methods:

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __repr__

    Convert to string

Attributes:

Properties property writable

Get the General opening properties

__init__ overloaded

__init__()

Initialize

__init__(
    openingProp: DoorOpeningProperties,
    generalEle: BaseElementAdapter,
    startPnt: Point2D,
    endPnt: Point2D,
    drawPlacementPreview: bool,
)

Constructor

Parameters:

  • openingProp (DoorOpeningProperties) –

    Opening properties

  • generalEle (BaseElementAdapter) –

    General element which includes the opening

  • startPnt (Point2D) –

    Start point of the opening

  • endPnt (Point2D) –

    End point

  • drawPlacementPreview (bool) –

    Draw as placement preview (no wall adaptions) state

__init__(element: DoorOpeningElement)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert to string