Skip to content

StructuralColumnProperties

Canonical path: NemAll_Python_ArchElements.StructuralColumnProperties

Bases: StructuralElementProperties, ArchBaseProperties

Representation of the properties of the structural framing column

Methods:

GetHeight

GetHeight() -> float

Get the Column Height

Returns:

  • float

    Column Height

GetPosition

GetPosition() -> Point3D

Get the Column position in world coordinate system

Returns:

  • Point3D

    Column position in world coordinate system

SetAnchorPointProperties

SetAnchorPointProperties(anchorPoint: int, offset: Point2D)

Set the Column Anchor Point Properties

Values for anchor point

1 - LeftBottom 2 - RightBottom 3 - RightTop 4 - LeftTop 5 - Center 6 - MiddleBottom 7 - MiddleRight 8 - MiddleTop 9 - MiddleLeft

10 - CenterOfGravity

Parameters:

  • anchorPoint (int) –

    Anchor point position

  • offset (Point2D) –

    Offset from start anchor point

SetHeight

SetHeight(
    height: float, doc: DocumentAdapter, heightRefereces: PlaneReferences
)

Set Column Height

Parameters:

  • height (float) –

    Height

  • doc (DocumentAdapter) –

    Document

  • heightRefereces (PlaneReferences) –

    Height Properties of Column, as PlaneReferences type

SetHeightProperties

SetHeightProperties(doc: DocumentAdapter, value: PlaneReferences)

Set height properties

Parameters:

  • doc (DocumentAdapter) –

    Document

  • planeReferences

    Height properties as PlaneReferences object

SetHeightPropsByPlacementPoint

SetHeightPropsByPlacementPoint(
    doc: DocumentAdapter, value: PlaneReferences, startPointZcoord: float
)

Set HeightProperties by a placement point

Parameters:

  • doc (DocumentAdapter) –

    Document

  • value (PlaneReferences) –

    Height Properties of Column, as PlaneReferences type

  • startPointZcoord (float) –

    Z coordinate start point

SetPosition

SetPosition(x: float, y: float, z: float)

Set the position of the column in world coordinate system

Parameters:

  • x (float) –

    x coordinate

  • y (float) –

    y coordinate

  • z (float) –

    z coordinate

__init__ overloaded

__init__()

Initialize

__init__(value: StructuralColumnProperties)

Constructor

Parameters: