Skip to content

eBoxPoint

Canonical path: NemAll_Python_Geometry.eBoxPoint

Bases: Enum

Get world point of a dedicated location of the box

eLeftBottom : 4----8----3 eRightBottom : | | eRightTop : 9 5 7 eLeftTop : | | eCenter : 1----6----2 eMiddleBottom: eMiddleRight : eMiddleTop : eMiddleLeft :

Attributes:

eCenter class-attribute instance-attribute

eCenter = 5

eLeftBottom class-attribute instance-attribute

eLeftBottom = 1

eLeftTop class-attribute instance-attribute

eLeftTop = 4

eMiddleBottom class-attribute instance-attribute

eMiddleBottom = 6

eMiddleLeft class-attribute instance-attribute

eMiddleLeft = 9

eMiddleRight class-attribute instance-attribute

eMiddleRight = 7

eMiddleTop class-attribute instance-attribute

eMiddleTop = 8

eRightBottom class-attribute instance-attribute

eRightBottom = 2

eRightTop class-attribute instance-attribute

eRightTop = 3