Skip to content

ClosedArea2D

Canonical path: NemAll_Python_Geometry.ClosedArea2D

2D closed area Representation class for 2D geometry closed (path bounded) area

Methods:

  • AddInnerCurve

    Add new inner curve

  • Clear

    Clear all the components of this Area

  • GetInnerCurve

    Get the curve of given index

  • GetInnerList

    Get the list of the inner curves

  • GetOuterCurve

    Get the outer curve of this area

  • InnerCount

    Get the count of inner curves

  • IsValid

    Set Check the validity

  • SetOuterCurve

    Set new Outer curve ( bounds )

  • __eq__

    Comparison of closedAreas without tolerance.

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __repr__

    Convert the list to a string

Attributes:

  • InnerList (None) –

    Get the inner path list as property

  • OuterCurve (None) –

    Get and set the outer path as property

InnerList property

InnerList: None

Get the inner path list as property

:type: None

OuterCurve property

OuterCurve: None

Get and set the outer path as property

:type: None

AddInnerCurve

AddInnerCurve(innerpath: Path2D) -> bool

Add new inner curve

Parameters:

  • innerpath (Path2D) –

    New inner curve ( Path2D )

Returns:

  • bool

    true if the operation was successful

Clear

Clear()

Clear all the components of this Area

GetInnerCurve

GetInnerCurve(index: int) -> Path2D

Get the curve of given index

Parameters:

  • index (int) –

    Index of the inner curve

Returns:

  • Path2D

    const reference to the curve ( Path2D )

GetInnerList

GetInnerList() -> Path2DList

Get the list of the inner curves

Returns:

  • Path2DList

    reference to a vector that contains the inner curves ( Path2D )

GetOuterCurve

GetOuterCurve() -> Path2D

Get the outer curve of this area

Returns:

  • Path2D

    const reference to outer curve ( Path2D )

InnerCount

InnerCount() -> int

Get the count of inner curves

Returns:

  • int

    count of inner curves

IsValid

IsValid() -> bool

Set Check the validity

Returns:

  • bool

    true if this Area is valid

SetOuterCurve

SetOuterCurve(outerpath: Path2D)

Set new Outer curve ( bounds )

Parameters:

  • outerpath (Path2D) –

    New outer curve ( Path2D )

__eq__

__eq__(closedArea: ClosedArea2D) -> object

Comparison of closedAreas without tolerance.

Be careful, this method work without tolerance!

Parameters:

Returns:

  • object

    True when closedAreas are equal, otherwise false.

__init__ overloaded

__init__()

Initialize

__init__(area: ClosedArea2D)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string