Skip to content

RefPointPosition

Canonical path: NemAll_Python_Palette.RefPointPosition

Bases: Enum

Definition of the reference point positions get from the RefPointButton

eNone : eTopLeft : eTopCenter : eTopRight : eCenterLeft : eCenterCenter: eCenterRight : eBottomLeft : eBottomCenter: eBottomRight :

Attributes:

eBottomCenter class-attribute instance-attribute

eBottomCenter = 8

eBottomLeft class-attribute instance-attribute

eBottomLeft = 7

eBottomRight class-attribute instance-attribute

eBottomRight = 9

eCenterCenter class-attribute instance-attribute

eCenterCenter = 5

eCenterLeft class-attribute instance-attribute

eCenterLeft = 4

eCenterRight class-attribute instance-attribute

eCenterRight = 6

eNone class-attribute instance-attribute

eNone = 0

eTopCenter class-attribute instance-attribute

eTopCenter = 2

eTopLeft class-attribute instance-attribute

eTopLeft = 1

eTopRight class-attribute instance-attribute

eTopRight = 3