Skip to content

ReinforcementService

Canonical path: NemAll_Python_Reinforcement.ReinforcementService

Reinforcement service

Classes:

Methods:

BarShapeCodeStandard

Canonical path: NemAll_Python_Reinforcement.ReinforcementService.BarShapeCodeStandard

Bases: Enum

Standard for the bar shape code

Methods:

__getitem__

__getitem__(key: str | int | float) -> BarShapeCodeStandard

get the item for a key

Parameters:

  • key (str | int | float) –

    value key

Returns:

GetACIBarMark staticmethod

GetACIBarMark(
    barsDefinitionElement: BaseElementAdapter, showIndex: bool
) -> list

Get the bar mark

Parameters:

  • barsDefinitionElement (BaseElementAdapter) –

    Bars definition element

  • showIndex (bool) –

    Show the index

Returns:

  • list

    bar mark for ACI

GetACIPlacementBarMark staticmethod

GetACIPlacementBarMark(
    barsPlacementElement: BaseElementAdapter, showIndex: bool
) -> tuple

Get the bar mark for a placement

Parameters:

  • barsPlacementElement (BaseElementAdapter) –

    Bars placement element

  • showIndex (bool) –

    Show the index

Returns:

  • tuple

    tuple(bar mark for ACI, bar count)

GetBarPositionData staticmethod

GetBarPositionData(elementVec: BaseElementAdapterList) -> list

Get the bar position data

Parameters:

Returns:

  • list

    List with the bar position data

GetBarShapeCode staticmethod

GetBarShapeCode(
    barsDefinitionElement: BaseElementAdapter,
    barShapeCopdeStandard: BarShapeCodeStandard,
) -> tuple

Get the bar shape code

Parameters:

Returns:

  • tuple

    shape code count, list of (shape codes, bar length), list of (segment name, segment lengths)) for ACI

  • tuple

    shape code count, list of shape codes, list of lengths) for all other