Skip to content

GeometryEdge

Canonical path: NemAll_Python_Geometry.GeometryEdge

Geometry edge Identification of any edge via point indices, not via point coordinates.

Methods:

Attributes:

  • EndIndex (None) –

    Get and set the end index property

  • StartIndex (None) –

    Get and set the start index property

EndIndex property

EndIndex: None

Get and set the end index property

:type: None

StartIndex property

StartIndex: None

Get and set the start index property

:type: None

GetEndIndex

GetEndIndex() -> int

Get end index

Returns:

  • int

    End index.

GetStartIndex

GetStartIndex() -> int

Get start index

Returns:

  • int

    Start index.

Set

Set(edge: Kanten_t)

Initialize edge from old Allplan structure

Parameters:

  • edge (Kanten_t) –

    Edge which will be copied.

SetEndIndex

SetEndIndex(index: int)

Set end index

Index is not checked, you set anything.

Parameters:

  • index (int) –

    End index.

SetStartIndex

SetStartIndex(index: int)

Set start index

Index is not checked, you set anything.

Parameters:

  • index (int) –

    Start index.

__eq__

__eq__(edge: GeometryEdge) -> object

Comparison of edges without tolerance.

Be careful, this method work without tolerance!

Parameters:

Returns:

  • object

    True when edges are equal, otherwise false.

__init__ overloaded

__init__()

Initialize

__init__(startIndex: int, endIndex: int)

Constructor

Parameters:

  • startIndex (int) –

    Start index of vertex.

  • endIndex (int) –

    End index of vertex.

__init__(edge: GeometryEdge)

Copy constructor

Parameters:

__init__(edge: Kanten_t)

Copy constructor from old Allplan structure

Parameters:

  • edge (Kanten_t) –

    Edge which will be copied.

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string