Skip to content

MacroPlacementProperties

Canonical path: NemAll_Python_BasisElements.MacroPlacementProperties

Properties of the macro placement

Methods:

  • __eq__

    equal operator

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __repr__

    Convert to string

Attributes:

  • BillingCategory (int) –

    Get the Billing category

  • ConsiderType (ConsiderType) –

    The type of adaptation behavior of the smart symbol relative to finishing surfaces

  • Craft (int) –

    Get the Craft

  • DistortionState (bool) –

    Whether to allow the resize of the smart symbol

  • DomainType (int) –

    Get the Domain type?

  • HasParentModificationBehaviour (bool) –

    Get the Specific behavior for modification

  • HeightDefinitionType (HeightDefinitionType) –

    Get the Height definition type

  • InOpeningState (bool) –

    Get the Is the macro placement inside opening ?

  • LeadingMacro (bool) –

    Is the macro placement a leading macro

  • LinkType (LinkType) –

    Get the Link type

  • Mass_V6 (float) –

    Get the Mass attribute V6

  • Mass_V7 (float) –

    Get the Mass attribute V7

  • Mass_V8 (float) –

    Get the Mass attribute V8

  • Mass_V9 (float) –

    Get the Mass attribute V9

  • Matrix (Matrix3D) –

    Get the Matrix for location in world coordinate system

  • MirrorState (bool) –

    Get the Was the macro placement mirrored ?

  • Name (str) –

    Get the Name

  • PositionNr (int) –

    Get the Unit factor

  • SubType (int) –

    Get the Subtype?

  • Type (int) –

    Get the Type?

  • UnitFactor (float) –

    Get the Unit factor

  • UseAlways2DRepInGroundView (bool) –

    Get the Use always 2D representation in ground view

  • UseDrawOrder (bool) –

    Set to True to use the draw order (sequence) setting of the smart symbol's instance. Set to False to use the setting of elements included in the macro slide

  • UseFormat (bool) –

    Set to True to use the format setting (pen, stroke, color) of the smart symbol's instance. Set to False to use the settings of the elements included in the macro slide.

BillingCategory property writable

BillingCategory: int

Get the Billing category

ConsiderType property writable

ConsiderType: ConsiderType

The type of adaptation behavior of the smart symbol relative to finishing surfaces

Craft property writable

Craft: int

Get the Craft

DistortionState property writable

DistortionState: bool

Whether to allow the resize of the smart symbol

DomainType property writable

DomainType: int

Get the Domain type?

HasParentModificationBehaviour property writable

HasParentModificationBehaviour: bool

Get the Specific behavior for modification

HeightDefinitionType property writable

HeightDefinitionType: HeightDefinitionType

Get the Height definition type

InOpeningState property writable

InOpeningState: bool

Get the Is the macro placement inside opening ?

LeadingMacro property writable

LeadingMacro: bool

Is the macro placement a leading macro

LinkType property writable

LinkType: LinkType

Get the Link type

Mass_V6 property writable

Mass_V6: float

Get the Mass attribute V6

Mass_V7 property writable

Mass_V7: float

Get the Mass attribute V7

Mass_V8 property writable

Mass_V8: float

Get the Mass attribute V8

Mass_V9 property writable

Mass_V9: float

Get the Mass attribute V9

Matrix property writable

Matrix: Matrix3D

Get the Matrix for location in world coordinate system

MirrorState property writable

MirrorState: bool

Get the Was the macro placement mirrored ?

Name property writable

Name: str

Get the Name

PositionNr property writable

PositionNr: int

Get the Unit factor

SubType property writable

SubType: int

Get the Subtype?

Type property writable

Type: int

Get the Type?

UnitFactor property writable

UnitFactor: float

Get the Unit factor

UseAlways2DRepInGroundView property writable

UseAlways2DRepInGroundView: bool

Get the Use always 2D representation in ground view

UseDrawOrder property writable

UseDrawOrder: bool

Set to True to use the draw order (sequence) setting of the smart symbol's instance. Set to False to use the setting of elements included in the macro slide

UseFormat property writable

UseFormat: bool

Set to True to use the format setting (pen, stroke, color) of the smart symbol's instance. Set to False to use the settings of the elements included in the macro slide.

__eq__

__eq__(prop: MacroPlacementProperties) -> bool

equal operator

Parameters:

Returns:

  • bool

    true if they are equal, false otherwise

__init__ overloaded

__init__()

Initialize

__init__(element: MacroPlacementProperties)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert to string