Skip to content

LayoutSize

Canonical path: NemAll_Python_BaseElements.LayoutSize

Data class containing information about the sheet size of a print layout.

Methods:

Attributes:

  • Height (None) –

    Layout height

  • Index (None) –

    Index

  • Name (None) –

    Name of the layout size, e.g. "DIN A4"

  • UserDefined (None) –

    Whether the size of the print layout should be defined freely by width & height, or to use predefined size defined in the property name.

  • Width (None) –

    Layout width

Height property

Height: None

Layout height

Index property

Index: None

Index

Name property

Name: None

Name of the layout size, e.g. "DIN A4"

UserDefined property

UserDefined: None

Whether the size of the print layout should be defined freely by width & height, or to use predefined size defined in the property name.

Width property

Width: None

Layout width

__init__

__init__()

Initialize