Skip to content

SelectionMode

Canonical path: NemAll_Python_IFW_Input.SelectionMode

Bases: Enum

Possible selection modes for multiple selection using InputFunctionStarter

Attributes:

  • eSelectGeometry

    Result of the selection is only the selected element

  • eSelectObject

    Result of the selection is the selected element with all its related elements (e.g. wall tier together with axis, labels, attribute container, etc...) and all child elements (if existing)

  • eSelectSubObject

    Result of the selection is the selected element with some related elements (e.g. wall tier with labels and attribute container)

eSelectGeometry class-attribute instance-attribute

eSelectGeometry = 0

Result of the selection is only the selected element

eSelectObject class-attribute instance-attribute

eSelectObject = 1

Result of the selection is the selected element with all its related elements (e.g. wall tier together with axis, labels, attribute container, etc...) and all child elements (if existing)

eSelectSubObject class-attribute instance-attribute

eSelectSubObject = 3

Result of the selection is the selected element with some related elements (e.g. wall tier with labels and attribute container)