Skip to content

ReinforcementLabelProperties

Canonical path: NemAll_Python_Reinforcement.ReinforcementLabelProperties

Methods:

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __repr__

    Convert the list to a string

Attributes:

ShowBarCount property

ShowBarCount: None

Set/get the show state for the bar count

:type: None

ShowBarDiameter property

ShowBarDiameter: None

Set/get the show state for the bar diameter

:type: None

ShowBarDistance property

ShowBarDistance: None

Set/get the show state for the bar distance

:type: None

ShowBarLayer property

ShowBarLayer: None

Set/get the show state for the bar layer

:type: None

ShowBarLength property

ShowBarLength: None

Set/get the show state for the bar length

:type: None

ShowBarPlace property

ShowBarPlace: None

Set/get the show state for the bar place

:type: None

ShowBendingShape property

ShowBendingShape: None

Set/get the show state for the bending shape

:type: None

ShowPositionAtEnd property

ShowPositionAtEnd: None

Set/get the show state for the bar diameter

:type: None

ShowPositionNumber property

ShowPositionNumber: None

Set/get the show state for the position number

:type: None

ShowSteelGrade property

ShowSteelGrade: None

Set/get the show state for the steel grade

:type: None

ShowTwoLineText property

ShowTwoLineText: None

Set/get the show state for the two line text

:type: None

__init__ overloaded

__init__()

Initialize

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string