Skip to content

VerticalOpeningFacingProperties

Canonical path: NemAll_Python_ArchElements.VerticalOpeningFacingProperties

Implementation of the vertical opening facing properties

Methods:

Attributes:

LeftDepth property writable

LeftDepth: float

Get the left depth

LeftFacing property writable

LeftFacing: bool

Get the left facing state

LeftWidth property writable

LeftWidth: float

Get the left width

OpeningSide property writable

OpeningSide: OpeningSide

Get the opening side

RightDepth property writable

RightDepth: float

Get the right depth

RightFacing property writable

RightFacing: bool

Get the right facing state

RightWidth property writable

RightWidth: float

Get the right width

TopDepth property writable

TopDepth: float

Get the top depth

TopFacing property writable

TopFacing: bool

Get the top facing state

TopWidth property writable

TopWidth: float

Get the top width

__init__

Copy constructor

Parameters: