Skip to content

PolyhedronFace

Canonical path: NemAll_Python_Geometry.PolyhedronFace

Polyhedron face All constructors are prohibited, only Polyhedron3D can instantiate this class. This behavior is dependant on old %Allplan architecture and can be changed.

Methods:

  • AppendEdge

    dummy, is only needed for the creation of the documentation by MkDocs

  • AppendEdges

    Append edges into face

  • GetEdge

    Get the edge index on specified position

  • GetEdges

    Get the edge index on specified position

  • GetEdgesCount

    Get count of edges

  • GetFlags

    Get the flags of the face

  • SetFlags

    Set the flags of the face

  • __getitem__

    Get the edge index on specified position

  • __init__

    Standard copy constructor

  • __repr__

    Convert the list to a string

AppendEdge overloaded

AppendEdge(edgeHandle: int, positiveOrientation: bool)

Append edge into face

Parameters:

  • edgeHandle (int) –

    Appended EdgeHandle.

  • positiveOrientation (bool) –

    True for positive, false for negative orientation.

AppendEdge(edge: OrientedEdge)

Append edge into face

Parameters:

AppendEdges

AppendEdges(edges: OrientedEdgeList)

Append edges into face

Parameters:

GetEdge

GetEdge(edgeIndex: int) -> tuple

Get the edge index on specified position

Old interface: getFaceEdge

Parameters:

  • edgeIndex (int) –

    Specified position in edge vector.

Returns:

  • tuple

    False when edgeIndex is out of range or when occurred another error, otherwise true.,

  • tuple

    Edge index.

GetEdges

GetEdges() -> OrientedEdgeList

Get the edge index on specified position

Returns:

GetEdgesCount

GetEdgesCount() -> int

Get count of edges

Old interface: getFaceEdgeCount

Returns:

  • int

    Count of edges.

GetFlags

GetFlags() -> int

Get the flags of the face

Returns:

  • int

    Face flags.

SetFlags

SetFlags(flags: int)

Set the flags of the face

Parameters:

  • flags (int) –

    Face flags.

__getitem__

__getitem__(edgeIndex: int) -> OrientedEdge

Get the edge index on specified position

Method can throw exception when index is out of range. Please use the GetEdgeIndex with return flag when you do not used exception handler. Old interface: getFaceEdge

Parameters:

  • edgeIndex (int) –

    Specified position in edge vector.

Returns:

__init__

__init__(face: PolyhedronFace)

Standard copy constructor

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string