Skip to content

Symbol2DElement

Canonical path: NemAll_Python_BasisElements.Symbol2DElement

Bases: BasisElement, AllplanElement

Representation of the point symbol in Allplan

Methods:

GetSymbol2DProperties

GetSymbol2DProperties() -> Symbol2DProperties

Get the Symbol2D properties

Returns:

SetSymbol2DProperties

SetSymbol2DProperties(symbol2DProp: Symbol2DProperties)

Set the Symbol2D properties

Parameters:

__init__ overloaded

__init__()

Initialize

__init__(
    commonProp: CommonProperties,
    Symbol2DProp: Symbol2DProperties,
    geometryObject: object,
)

Constructor

Parameters:

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string