Skip to content

HatchingElement

Canonical path: NemAll_Python_BasisElements.HatchingElement

Bases: BasisElement, AllplanElement

Representation of the hatching in Allplan

Methods:

Attributes:

HatchingProperties property writable

HatchingProperties: HatchingProperties

Get the hatching properties

GetHatchingProperties

GetHatchingProperties() -> HatchingProperties

Get the hatching properties

Returns:

SetHatchingProperties

SetHatchingProperties(hatchingProp: HatchingProperties)

Set the hatching properties

Parameters:

__init__ overloaded

__init__()

Initialize

__init__(
    commonProp: CommonProperties,
    hatchingProp: HatchingProperties,
    polygon: Polygon2D,
)

Constructor

Parameters:

__init__(element: HatchingElement)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert to string