Skip to content

InputViewDocumentData

Canonical path: NemAll_Python_IFW_Input.InputViewDocumentData

Implementation of the functions for the input view and document data

Methods:

EnableAssistWndClick

EnableAssistWndClick(bEnable: bool)

Enable/disable a click inside the assist window

Parameters:

  • bEnable (bool) –

    Enable a click inside the assist window: 1/0

GetActiveViewDocument

GetActiveViewDocument() -> DocumentAdapter

Get the active view document

Returns:

GetInputViewDocument

GetInputViewDocument() -> DocumentAdapter

Get the input view document

Returns:

GetInputViewDocumentID

GetInputViewDocumentID() -> int

Get the document ID of the current input view.

Returns:

  • int

    Document ID of the current input view

GetViewWorldProjection

GetViewWorldProjection() -> ViewWorldProjection

Get the view-world projection object

Returns: