Skip to content

IntersectionRayPolyhedron

Canonical path: NemAll_Python_Geometry.IntersectionRayPolyhedron

Intersection result of the ray - Polyhedron3D intersection

Methods:

Attributes:

  • FaceIdx (int) –

    face index of the face of the best intersection (if found, not unique) beginning from 0

  • FaceNv (Vector3D) –

    normal vector of best-intersected face (if found, not unique)

  • IntersectionPoint (Point3D) –

    intersection point (if found)

  • Lambda (float) –

    ray parameter of returned intersection (if found)

  • RetCode (int) –

    return code: 0: no inters.,

FaceIdx property writable

FaceIdx: int

face index of the face of the best intersection (if found, not unique) beginning from 0

FaceNv property writable

FaceNv: Vector3D

normal vector of best-intersected face (if found, not unique)

IntersectionPoint property writable

IntersectionPoint: Point3D

intersection point (if found)

Lambda property writable

Lambda: float

ray parameter of returned intersection (if found)

RetCode property writable

RetCode: int
0: no inters.,

1: pos. inters. found,

-1: only neg. inters. found

__init__

__init__(element: IntersectionRayPolyhedron)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert to string